import re
regex = re.compile(r"(\w+)=(\[.*?]|{.*?}|\S+)(?=\s*,\s*\w+=|$)", flags=re.MULTILINE)
test_str = "names=['m','c'], nmodes=2, mus=[[-5.0, -5.0], [5.0, 5.0]], sigmas=[[1.5, 1.5], [2.1, 2.1]], corrcoefs=[[[1.0, -0.7], [-0.7, 1.0]], [[1.0, 0.7], [0.7, 1.0]]], covs=[[[2.25, -1.5749999999999997], [-1.5749999999999997, 2.25]], [[4.41, 3.087], [3.087, 4.41]]], weights=[1.0, 3.0], bounds={'m': (-inf, inf), 'c': (-inf, inf)}"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")