import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\b(Fat(\\W?|\\W?\\b.*\\b)(Bike|Trike))\\b";
final String string = "My father's fat bike is a fat tyre bike.\n"
+ "My father's fat-bike is a fat tyre bike.\n"
+ "My father's Fat Tyre Electric Bike.\n"
+ "My father's fat-bike.\n"
+ "My father's fat, bike.\n"
+ "My father's fat, tyre, bike.\n"
+ "My father's fat, tyre, electric-bike.\n"
+ "My father's fat, tyre, electric bike.\n"
+ "My father's fat, tyre. Electric bike.\n"
+ "My father's fat-tyre, electric bike.\n"
+ "My father's fat, tyre, electric Trike.\n"
+ "#FatBike\n"
+ "#Fat-Bike\n"
+ "#Fat-Tyre-Bike\n"
+ "#FatTrike\n"
+ "My father's fat motorbike.\n"
+ "My father's fat tyre motorbike.\n"
+ "My father's lefat tyre electric bike.\n"
+ "My father's fat tyre electric biker.\n"
+ "My father's fat1 tyre, electric bike.\n"
+ "My father's fatt tyre, electric bike.\n"
+ "#FatTyreBike\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}