// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)\b(Fat(\W?|\W?\b.*\b)(Bike|Trike))\b").unwrap();
let string = "My father's fat bike is a fat tyre bike.
My father's fat-bike is a fat tyre bike.
My father's Fat Tyre Electric Bike.
My father's fat-bike.
My father's fat, bike.
My father's fat, tyre, bike.
My father's fat, tyre, electric-bike.
My father's fat, tyre, electric bike.
My father's fat, tyre. Electric bike.
My father's fat-tyre, electric bike.
My father's fat, tyre, electric Trike.
#FatBike
#Fat-Bike
#Fat-Tyre-Bike
#FatTrike
My father's fat motorbike.
My father's fat tyre motorbike.
My father's lefat tyre electric bike.
My father's fat tyre electric biker.
My father's fat1 tyre, electric bike.
My father's fatt tyre, electric bike.
#FatTyreBike
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}