# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}/const $1 = $2 =>\n actionCreator($3))/g;t' <<< "export function crap(one,two,three) {
return {
one,
two,
three
}
}
export function crapTwo(one,two,three) {
return {
one,
two,
three
}
}"