#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}"
Local $sString = "export function crap(one,two,three) {" & @CRLF & _
" return {" & @CRLF & _
" one," & @CRLF & _
" two," & @CRLF & _
" three" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
"export function crapTwo(one,two,three) {" & @CRLF & _
" return {" & @CRLF & _
" one," & @CRLF & _
" two," & @CRLF & _
" three" & @CRLF & _
" }" & @CRLF & _
"}"
Local $sSubst = "const $1 = $2 =>\n actionCreator($3))"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)