import Foundation
let pattern = #"export function(.*)(\(.*\))\s{\n.*return.*{((.*\n){3,9})}"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
export function crap(one,two,three) {
return {
one,
two,
three
}
}
export function crapTwo(one,two,three) {
return {
one,
two,
three
}
}
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"const $1 = $2 =>\n actionCreator($3))"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)