const regex = /(="|<)?\b(https?|ftp)(:\/\/[-A-Z0-9+&@#\/%?=~_|[\]()!:,.;]*[-A-Z0-9+&@#\/%=~_|[\])])(?=$|\W)/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(="|<)?\\b(https?|ftp)(:\\\/\\\/[-A-Z0-9+&@#\\\/%?=~_|[\\]()!:,.;]*[-A-Z0-9+&@#\\\/%=~_|[\\])])(?=$|\\W)', 'gi')
const str = `https://cache-elastic-pandora.ecn.cl/emol/noticia/_search?q=publicada:true+AND+ultimoMinuto:true+AND+seccion:*+AND+temas.id:*&sort=fechaModificacion:desc&size=15&from=45`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}