#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^https?:\/\/sodaphonic.com\/audio\/([a-zAA-Z0-9]+)(.*)$"
Local $sString = "https://sodaphonic.com/audio/344uhz2j8NUJjyUkckQq" & @CRLF & _
"https://sodaphonic.com/boombox" & @CRLF & _
"https://twitter.com/sodaphonic/status/1529218638712020995" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")