import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^https?:\\/\\/sodaphonic.com\\/audio\\/([a-zAA-Z0-9]+)(.*)$";
final String string = "https://sodaphonic.com/audio/344uhz2j8NUJjyUkckQq\n"
+ "https://sodaphonic.com/boombox\n"
+ "https://twitter.com/sodaphonic/status/1529218638712020995\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}