# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/{{\s*(\w*)\s*}}(?=[^%]*%})/\$$1/gm;t' <<< "sometext {% {{ var1 }} middletext {{ var2 }} %} moretext {{ varx }} {% {{ var3 }} %}"