const regex = /{{\s*(\w*)\s*}}(?=[^%]*%})/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('{{\\s*(\\w*)\\s*}}(?=[^%]*%})', 'gm')
const str = `sometext {% {{ var1 }} middletext {{ var2 }} %} moretext {{ varx }} {% {{ var3 }} %}`;
const subst = `\$$1`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);