re = /{{\s*(\w*)\s*}}(?=[^%]*%})/m
str = 'sometext {% {{ var1 }} middletext {{ var2 }} %} moretext {{ varx }} {% {{ var3 }} %}'
subst = '\\$$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result