import Foundation
let pattern = #"{{\s*(\w*)\s*}}(?=[^%]*%})"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"sometext {% {{ var1 }} middletext {{ var2 }} %} moretext {{ varx }} {% {{ var3 }} %}"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\$$1"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)