$re = '/^(?=[a-z0-9-]{1,52}$)[a-z0-9]+(?:-[a-z0-9]+){0,2}$/mi';
$str = 'abc-123
abc-123-abc
-abc-123
abc-123-
abc-123-abc-123
abc-12#-abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);