const regex = new RegExp('[\\w\\.]+@[\\w\\.]+\\.\\w+', 'gm')
const str = `send : .host@server.com
recv : guest@client.com
return : admin_1@test.server.com
fwd : admin.programming@test.server.co.kr`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}