re = /[\w\.]+@[\w\.]+\.\w+/m
str = 'send : .host@server.com
recv : guest@client.com
return : admin_1@test.server.com
fwd : admin.programming@test.server.co.kr'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end