package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?<board>.*)\s?branch:(?<branch>.*)\s+sdk:(?<sdk>.*)\s+foundation:(?<foundation>.*)\s+tegra:(?<tegra>.*)\s+dgpu:(?<dgpu>.*)`)
var str = `branch:embedded-5.2.9.0 sdk:0003 foundation:0003 tegra:x1 dgpu:TU104-600-CS`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}