use strict;
my $str = 'branch:embedded-5.2.9.0 sdk:0003 foundation:0003 tegra:x1 dgpu:TU104-600-CS';
my $regex = qr/(?<board>.*)\s?branch:(?<branch>.*)\s+sdk:(?<sdk>.*)\s+foundation:(?<foundation>.*)\s+tegra:(?<tegra>.*)\s+dgpu:(?<dgpu>.*)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}