import Foundation
let pattern = #"(?<board>.*)\s?branch:(?<branch>.*)\s+sdk:(?<sdk>.*)\s+foundation:(?<foundation>.*)\s+tegra:(?<tegra>.*)\s+dgpu:(?<dgpu>.*)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"branch:embedded-5.2.9.0 sdk:0003 foundation:0003 tegra:x1 dgpu:TU104-600-CS"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)