package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)url\((.*?)\)`)
var str = `style='background-image: url(MATCH TARGET); background-size: cover; background-position: center; background-repeat: no-repeat;'
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}