$re = '/url\((.*?)\)/m';
$str = 'style=\'background-image: url(MATCH TARGET); background-size: cover; background-position: center; background-repeat: no-repeat;\'
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);