# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(^\D*\d+\D*)(\w*\s+)(\d*\s+)(\d*\s+)(\d*\s+\d*\s+\d*\s+\d*\s+\d*\s+)(\w+)"
test_str = (" 2555 texttext 0 100 100 0 0 0 0 lowness 0\n"
" 2557 texttext 10 650 660 0 0 0 0 lowness 0\n"
" 2564 texttext 0 30 30 0 0 0 0 lowness 0\n"
" 2566 texttext 0 0 0 0 0 0 0 lowness 0\n"
" 2567 texttext 10 70 80 0 0 0 0 lowness 0")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.