// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)^(?P<date>\d{4}-\d+-\d+)\s+(?P<time>\d+:\d+:\d+)\s+(?P<ip>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})\s+(?P<method>\w+)\s+(?P<uri>\/.*)\s+(?P<status>\d+)\s+(?P<bytes>\d+)\s+(?P<referer>\".*\")\s+(?P<useragent>\".*\")\s+(?P<cookie>\".*\")\s+(?P<custom>\".*\")\s+(?P<ghostip>\d{1,3}.\d{1,3}.\d{1,3}.\d{1,3})\s+(?P<cache>\d)\s+(?P<wafinfo>\".*\")$"#).unwrap();
let string = "#Fields: date time cs-ip cs-method cs-uri sc-status sc-bytes time-taken cs(Referer) cs(User-Agent) cs(Cookie) x-custom ghostip cache_status x-wafinfo
2023-11-17 07:33:55 217.165.96.151 GET /www.argos.co.uk/assets/common/polyfills/3.0.17/polyfills-request-idle-callback.min.js 200 1400 22 \"https://www.argos.co.uk/product/4660185?cjdata=MXxOfDB8WXww&$ja=tsid%3A11674%7Cprd%3A100072047&utm_source=Skimlinks&utm_medium=affiliates&utm_campaign=Argos+Deep+Generator+AID-+DO+NOT+CHANGE&utm_content=10830324&utm_custom1=100072047&utm_custom2=Other&cmpid=cojun&cjevent=a61535ab851b11ee8392ee230a1cb82a&dclid=CLv4hcTCyoIDFe9C9ggdWDMACA\" \"Mozilla/5.0 (iPhone; CPU iPhone OS 16_6_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.6 Mobile/15E148 Safari/604.1\" \"akaas_arg_uk_global=1707982435~rv=34~id=e302e31ea1f9450e13700fd5beee9884\" \"-\" 2.21.231.4 1 \"1111_3104||\"
2023-11-17 07:33:55 217.165.96.151 GET /www.argos.co.uk/assets/common/vendor/5.0.17/commonvendor-react.min.js 200 56746 23 \"https://www.argos.co.uk/product/4660185?cjdata=MXxOfDB8WXww&$ja=tsid%3A11674%7Cprd%3A100072047&utm_source=Skimlinks&utm_medium=affiliates&utm_campaign=Argos+Deep+Generator+AID-+DO+NOT+CHANGE&utm_content=10830324&utm_custom1=100072047&utm_custom2=Other&cmpid=cojun&cjevent=a61535ab851b11ee8392ee230a1cb82a&dclid=CLv4hcTCyoIDFe9C9ggdWDMACA\" \"Mozilla/5.0 (iPhone; CPU iPhone OS 16_6_1 like Mac OS X) AppleWebKit/605.1.15 (KHTML, like Gecko) Version/16.6 Mobile/15E148 Safari/604.1\" \"akaas_arg_uk_global=1707982435~rv=34~id=e302e31ea1f9450e13700fd5beee9884\" \"-\" 2.21.231.4 1 \"1111_3104||\"";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}