import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\`{3}[\\w|\\W]+?\\`{3})";
final String string = " ``` \n"
+ " block code \n"
+ " word1\n"
+ " word2\n"
+ " ```\n\n"
+ "word without grave accent and it is will match it too\n\n"
+ " ```\n"
+ " another block code\n"
+ " word1\n"
+ " word2\n"
+ " - it's will match it as part of the first block code\n"
+ " ```\n\n"
+ "\"\"\"\n"
+ "some text after the grave accent text\n"
+ "word1\n"
+ "word2\n"
+ "\"\"\"`";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}