use strict;
my $str = ' ```
block code
word1
word2
```
word without grave accent and it is will match it too
```
another block code
word1
word2
- it\'s will match it as part of the first block code
```
"""
some text after the grave accent text
word1
word2
"""`';
my $regex = qr/(\`{3}[\w|\W]+?\`{3})/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}