// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(\`{3}[\w|\W]+?\`{3})").unwrap();
let string = " ```
block code
word1
word2
```
word without grave accent and it is will match it too
```
another block code
word1
word2
- it's will match it as part of the first block code
```
\"\"\"
some text after the grave accent text
word1
word2
\"\"\"`";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}