#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<upc>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<date>[\d,a-z,A-Z]{1,70}))(\(\d{1,3}[0-9,a-z,A-Z]{1}?\)(?<batch>[\d,a-z,A-Z]{1,70}))"
Local $sString = "(01)30628242248564(13)220909(10)8563220909"
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)