use strict;
my $str = '1234566778
12334566
1234566678
1222
2221
66
122
221
111
12345654554888';
my $regex = qr/((\d)\2{2,})|\d(\d)\3(?!\3)\d/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}