const regex = /'time': (?P<Time>\w+\s\w+\s\d+\s\d+:\d+:\d{2}), 'type': (?P<Type>[a-zA-Z]+_\w+:\w+)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\'time\': (?P<Time>\\w+\\s\\w+\\s\\d+\\s\\d+:\\d+:\\d{2}), \'type\': (?P<Type>[a-zA-Z]+_\\w+:\\w+)', '')
const str = `{'time': Mon Jan 20 11:34:13, 'type': access_compat:error}`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}