$re = '/\'time\': (?P<Time>\w+\s\w+\s\d+\s\d+:\d+:\d{2}), \'type\': (?P<Type>[a-zA-Z]+_\w+:\w+)/';
$str = '{\'time\': Mon Jan 20 11:34:13, \'type\': access_compat:error}';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);