// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"'time': (?P<Time>\w+\s\w+\s\d+\s\d+:\d+:\d{2}), 'type': (?P<Type>[a-zA-Z]+_\w+:\w+)").unwrap();
let string = "{'time': Mon Jan 20 11:34:13, 'type': access_compat:error}";
// result will be a tuple containing the start and end indices for the first match in the string
let result = regex.captures(string);
let (start, end) = match result {
Some((s, e)) => (s, e),
None => {
// ...
}
};
println!("{}", &string[start, end]);
}