#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)(" & @CRLF & _
" \[ (?=\h*x)" & @CRLF & _
" |" & @CRLF & _
" (?<=x) \h* \K \]" & @CRLF & _
")"
Local $sString = "Yes: [x]" & @CRLF & _
"Yes: [ x]" & @CRLF & _
"Yes: [x ]" & @CRLF & _
"Yes: [ x ]" & @CRLF & _
"No: [" & @CRLF & _
"No: ]" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")