import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\n"
+ " \\[ (?=\\h*x)\n"
+ " |\n"
+ " (?<=x) \\h* \\K \\]\n"
+ ")";
final String string = "Yes: [x]\n"
+ "Yes: [ x]\n"
+ "Yes: [x ]\n"
+ "Yes: [ x ]\n"
+ "No: [\n"
+ "No: ]\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}