$re = '/(?:\[@[A-Za-z0-9]+\])/m';
$str = 'Hello [@foo] how are you [@bar] more text
Hello [@foauAOFUAFL] how are you [@08adfAF] more text';
$subst = "";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;