package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)(slovo(?:.+?$){6})`)
var str = `dfsdfsfjd
gfgjkhdfjkg
fsdkjfhsdkj slovo skjfhjkshdfjk
sd;lkf;sdlf
sdkfjsdklfj
dlskfjskldfj
ldskfjlksdfj
lsdfjlkdsjfkl
lsdkjfklsdfj
kldjflkdsj
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}