#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "Discussion:\n[a-zA-Z]{1,3}\s+\d{2}\/\d{2}\/\d{4}.*\n+(?<content>(?:.*\n)*)ABC Company Australia \| XYZ St \| Sydney NSW 2000"
Local $sString = "Discussion:" & @CRLF & _
"Tue 26/04/2022/2:48 PM UTC+10/ ABC User-" & @CRLF & _
"" & @CRLF & _
"TEST" & @CRLF & _
"" & @CRLF & _
"description - this should be" & @CRLF & _
"logged as a comment. --- This is" & @CRLF & _
"" & @CRLF & _
"the part I need" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"ABC Company Australia | XYZ St | Sydney NSW 2000" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")