package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)<[^<>]*\bname="[^"]*"[^<>]*>|([_!=+])`)
var str = `cat_dog_ !mouse= <test name="Jake_Russell!" a=1> gog+cat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}