package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\w+?)(\d+)`)
var str = `garbage0001`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}