$re = '~(#include "C:/Users.*\.h")$~m';
$str = '#include "C:/Users/{various paths to different headerfiles}.h>
#include "C:/Users/{various paths to different headerfiles}.h"';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);