#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?<=All User Profile\s+:\s).+"
Local $sString = "Profiles on interface Wi-Fi:" & @CRLF & _
"" & @CRLF & _
"Group policy profiles (read only)" & @CRLF & _
"---------------------------------" & @CRLF & _
" <None>" & @CRLF & _
"" & @CRLF & _
"User profiles" & @CRLF & _
"-------------" & @CRLF & _
" All User Profile : ModemN1" & @CRLF & _
" All User Profile : IsntModem" & @CRLF & _
"" & @CRLF & _
"Profiles on interface Wi-Fi:" & @CRLF & _
"" & @CRLF & _
"Group policy profiles (read only)" & @CRLF & _
"---------------------------------" & @CRLF & _
" <None>" & @CRLF & _
"" & @CRLF & _
"User profiles" & @CRLF & _
"-------------" & @CRLF & _
" All User Profile : somethingElse" & @CRLF & _
" All User Profile : another wlan"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")