const regex = /[ \n\t]*([a-zA-Z][a-zA-Z0-9_]*)[ \n\t]+((char)[ \n\t]*\[[ \n\t]*([0-9]+)[ \t\n]*\]|(char)|(int)|(double)|(bool)|(blob)[ \n\t]*\[[ \n\t]*([0-9]+)[ \t\n]*\])[ \n\t]*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[ \\n\\t]*([a-zA-Z][a-zA-Z0-9_]*)[ \\n\\t]+((char)[ \\n\\t]*\\[[ \\n\\t]*([0-9]+)[ \\t\\n]*\\]|(char)|(int)|(double)|(bool)|(blob)[ \\n\\t]*\\[[ \\n\\t]*([0-9]+)[ \\t\\n]*\\])[ \\n\\t]*', 'g')
const str = `cpf char[12]`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}