use strict;
my $str = '3/1/1/10=p3 12/mim1=eth11
3/1/1/11=p4 12/mim3=eth11
3/1/1/1=p1 12/mim2=eth11
3/1/1/12=p5 13/mim1=eth11
3/1/1/13=p6 13/mim3=eth11
3/1/1/2=p2 13/mim2=eth11
8/mim1=eth11 3/1/2/5=p7
8/mim2=eth11 3/1/2/6=p8
3/1/2/11=p9 4/mim1=eth11';
my $regex = qr/(?<=p)\d+|(?<=mim)\d+/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}