using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"((\w+|\-)+)(\W*):(?=(.+);)";
string input = @"#LasVegas .billboard { text-decoration: blink; }
.ninja, #Snowden { visibility: hidden; }
.oliveoil
{
z-index: 1;
}
.water
{
z-index: 0;
}
#poop {
float : none ;
color : brown ;
width : 15cm ;
height : 120cm ;
}
.God { position: absolute; display: none; }
#blackhole { padding: -9999em; }
.word { font-family: ""Comic Sans"", ""Times New Roman"", sans-serif ; }";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}