use strict;
my $str = '#LasVegas .billboard { text-decoration: blink; }
.ninja, #Snowden { visibility: hidden; }
.oliveoil
{
z-index: 1;
}
.water
{
z-index: 0;
}
#poop {
float : none ;
color : brown ;
width : 15cm ;
height : 120cm ;
}
.God { position: absolute; display: none; }
#blackhole { padding: -9999em; }
.word { font-family: "Comic Sans", "Times New Roman", sans-serif ; }';
my $regex = qr/((\w+|\-)+)(\W*):(?=(.+);)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}