re = /((\w+|\-)+)(\W*):(?=(.+);)/
str = '#LasVegas .billboard { text-decoration: blink; }
.ninja, #Snowden { visibility: hidden; }
.oliveoil
{
z-index: 1;
}
.water
{
z-index: 0;
}
#poop {
float : none ;
color : brown ;
width : 15cm ;
height : 120cm ;
}
.God { position: absolute; display: none; }
#blackhole { padding: -9999em; }
.word { font-family: "Comic Sans", "Times New Roman", sans-serif ; }'
# Print the match result
str.match(re) do |match|
puts match.to_s
end