import Foundation
let pattern = #"((\w+|\-)+)(\W*):(?=(.+);)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = ##"""
#LasVegas .billboard { text-decoration: blink; }
.ninja, #Snowden { visibility: hidden; }
.oliveoil
{
z-index: 1;
}
.water
{
z-index: 0;
}
#poop {
float : none ;
color : brown ;
width : 15cm ;
height : 120cm ;
}
.God { position: absolute; display: none; }
#blackhole { padding: -9999em; }
.word { font-family: "Comic Sans", "Times New Roman", sans-serif ; }
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}