$re = '/(?:^|(?<=[, ]))(?:next to|near|beside|opp).+?(?=,|$)/mi';
$str = 'Opp foobar, foocity" --> Must match "Opp foobar"
Fooplace, near barplace, barcity" --> Must match "near barplace"
Fooplace, Shoppers Stop, foocity"--> Must match nothing
Fooplace, opp barplace"--> Must match "opp barplace"
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);