using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(vendor\/devowl-wp\/[^\/]+\/languages\/frontend\/json\/)devowl-wp-";
string substitution = @"$1";
string input = @"/var/www/html/wp-content/plugins/real-category-library/vendor/devowl-wp/real-product-manager-wp-client/languages/frontend/json/devowl-wp-real-product-manager-wp-client-de_DE_formal-vendor-devowl-wp-real-product-manager-wp-client.json";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}