use strict;
my $str = '/var/www/html/wp-content/plugins/real-category-library/vendor/devowl-wp/real-product-manager-wp-client/languages/frontend/json/devowl-wp-real-product-manager-wp-client-de_DE_formal-vendor-devowl-wp-real-product-manager-wp-client.json';
my $regex = qr/(vendor\/devowl-wp\/[^\/]+\/languages\/frontend\/json\/)devowl-wp-/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";