$re = '/^(\+?34)?(6\d{2}|7[1-9]\d{1})\d{6}$/';
$str = '626615967';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);